What are the browser requirements for Norton’s sites?

Norton's Student Websites require Internet Explorer 6.0 or higher (PC), Safari 3.0 or higher, a Mozilla 5.0-compatible browser (i.e. Firefox, Mozilla Suite, Netscape 7.0, etc.), and Adobe's Flash Player 7.0 or higher.

In addition to the above above basic requirements, some sites may need additional plugins such as Apple Quicktime, Windows Media Player and/or the Adobe Acrobat Reader. Be sure to check the requirements for the site you're using.

To check if your browser meets these requirements, you can run our browser checker.